Skip to main content

MacOS 10.15 Catalina Compatibility and Support Notice

MacOS Catalina

Apple made macOS Catalina (10.15) available as of October 7, 2019. DICTS however recommends that students, faculty, and staff avoid upgrading to macOS Catalina on computers that are currently running OS X 10.14 Mojave or below until we complete compatibility testing. Since many older applications do not properly function with 10.15 and the upgrade process may render your computer non-operational, DICTS recommends that you do not upgrade your existing Apple computer to Catalina.

For more information about updating to Catalina, please get in touch with our personnel.

You can also visit our software/apps page for a list of available and recommended softwares to use within the Makerere community

Tags

© 2019 All rights reserved - Directorate for ICT Support (DICTS) - Makerere University

Available Office Time: 8:00am - 5:00pm (Monday - Friday)

Service Desk - https://support.mak.ac.ug

Email: helpme@dicts.mak.ac.ug
VOIP: 11 111
Phone: 0414 531343/437
Hours: 9:00am - 5:00pm